首页  /  烂笔头
dpkg出现“太多错误”时的修复

如果你翻遍了搜索引擎,按着大家的提示,运行了以下命令后,

sudo dpkg --configure -a
sudo apt-get -f install

还是无法自动修复的话,可以尝试像以下这样(这里的package就是那些提示有依赖问题的 软件包):

sudo aptitude download package1 package2 ...
sudo dpkg -i --fore-configure-any *.deb

如果非常不幸的连第二句命令也不成功的话,可以试着在这条命令之前加上 sudo dpkg --configure -a --force-configure-any看看……再不行的话,我也没辙了, 然后我确定你可以关掉这个页面了。

如果足够走运,通过上面的手动下载、跳过依赖计算并重新安装有问题的软件包后, 你应该可以……

sudo apt-get update
sudo apt-get upgrade

相关笔记